Subscription management not working

Incident Report for Meisterplan

Resolved

We see full recovery of all affected components
Posted Oct 20, 2025 - 11:22 UTC

Identified

We have noticed an issue with the subscription management due to an incident at our subscription management provider. This prevents purchases, upgrades and cancellations. The renewal of active subscriptions is not affected by this issue.

Please contact our support team if you wish to make any changes to your subscription until this issue is resolved.
https://help.meisterplan.com/hc/en-us/requests/new
Posted Oct 20, 2025 - 10:00 UTC
This incident affected: Meisterplan Application (EU Region) (Subscription Management) and Meisterplan Application (US Region) (Subscription Management).