Problem exporting Reports
Incident Report for Meisterplan
Resolved
The problem has been fixed
Posted Dec 11, 2023 - 12:55 UTC
Identified
We are investigating the problem and working on a fix
Posted Dec 11, 2023 - 12:25 UTC
This incident affected: Meisterplan Application (US Region) (Web Application) and Meisterplan Application (EU Region) (Web Application).