Jira Link does not work for some Jira Cloud instances
Incident Report for Meisterplan
Resolved
Atlassian marked the corresponding Atlassian-Incident as resolved and our logs show that the problem does not occur anymore.

Summary from Atlassian
"Since Monday 26th Feb some of Jira OAuth 2.0 REST calls that result in returning an empty or incomplete set of data for issue related endpoints (...).

Following rollback of the recently released code change on Feb 29th 12:20 UTC we haven't observed failures and haven't received any new reports. The incident is now resolved.

We apologise to all of our customers and users who were impacted during this time."
(Source: https://developer.status.atlassian.com/incidents/k4qd0kflm29v)
Posted Feb 29, 2024 - 19:38 UTC
Monitoring
Atlassian has identified root cause of the issue and resolved it by rolling back one of the recently released code changes.
(See https://developer.status.atlassian.com/incidents/k4qd0kflm29v for details).
We are monitoring this issue before confirming this incident as resolved.
Posted Feb 29, 2024 - 15:48 UTC
Update
Atlassian is still working on a fix for this problem.
See https://developer.status.atlassian.com/incidents/k4qd0kflm29v for curent progress.
Posted Feb 29, 2024 - 10:52 UTC
Identified
We are still waiting for feedback from Atlassian, where the problem could be reproduced.
Posted Feb 28, 2024 - 19:50 UTC
Update
We are continuing to monitor for any further issues.
Posted Feb 28, 2024 - 14:05 UTC
Monitoring
It turned out that the problem is not caused by Jira Link but is a general problem with Jira Clouud that also affects other applications.
Posted Feb 28, 2024 - 14:05 UTC
Update
Only some but not all Jira Cloud instances are affected by this problem.
Self-hosted Jira Server instances are generally not affected.
We are in contact with Atlassian and hope that the problem will be solved soon.
Posted Feb 28, 2024 - 12:15 UTC
Update
Since there was no change to this functionality in Meisterplan and the error occurs when calling the Atlassian API, we have escalated this problem to Atlassian.
Posted Feb 28, 2024 - 10:16 UTC
Identified
The Jira Link is currently not available. We are working on a solution.
Posted Feb 28, 2024 - 07:57 UTC
This incident affected: Meisterplan Application (EU Region) (API/Mobile App/Integrations) and Meisterplan Application (US Region) (API/Mobile App/Integrations).